Joomla!3.4 は、バージョンJoomla 3.3 の時から、PHPのバージョンがPHP5.3.10 以降のバージョンがインストール要件になりました。

従ってレンタルサーバー側が、PHP3.3.3 の様な下位バージョンでは、Joomla!3.4 はインストールできませんので、旧バージョン 3.2.4 をインストールする事になります。

Joomla 3.2 をインストールする方法 ⇒ Joomla3.3 が”インストール出来ない”問題

 

今使っているレンタルサーバーが、PHP3.3.3 であれば、PHPがバージョンアップされるのを待つしかありません。

そんな方でも、最新版のJoomla 3.4 をインストールする一つの対処法を紹介します。

【.htaccess】の先頭に、次の1行を追加してみてください。

-------

AddHandler x-httpd-php5.4 .php .phps

全てのサーバーに適応できる訳ではありません。

 

次に、Joomla 3.4 をサーバーにアップして起動すると、次のようなエラーが表示された場合の解決法。

Your host needs to use PHP 5.3.10 or higher to run this version of Joomla!

この場合には、あらかじめ

【.htaccess】ファイルの先頭行に

AddHandler x-httpd-php5.4 .php .phps 》を記載してアップしてから、起動してみてください。

アップデートと同様、お使いのサーバーによっては、解消しない場合がありますので、PHPがバージョンアップされるのを待ちましょう。

 

この時、システム設定で、『index.php』を含まないURLにする為、「URLリライトの使用」を「はい」に設定して、【htaccess.txt】のファイル名をリネームした時にも、先程の先頭行の追加も忘れないように・・・・・

参考記事

”Internal Server Error”が出る